ubuntu 10.04 do-release-upgrade gpg error

Hi

If you get an error message that the new precise (12.04) packages cannot be authenticated simply create the following file /etc/update-manager/release-upgrades.d/unauth.cfg
with following content

[Distro]
AllowUnauthenticated=yes

After upgrade delete the file

Have fun!