Tag Archives: cpu

debian jessie as kvm guest high cpu load

Hi

I was wondering about the high cpu load of my debian jessie kvm guests.

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+    COMMAND
 18 root 20 0     S           11,0      50:10.35 ksoftirqd/2
 28 root 20 0     S           11,0      49:45.90 ksoftirqd/4
 13 root 20 0     S           10,1      51:25.18 ksoftirqd/1
 23 root 20 0     S           10,1      55:42.26 ksoftirqd/3
 33 root 20 0     S           8,3       43:12.53 ksoftirqd/5
 3 root 20 0      S           7,4       43:19.93 ksoftirqd/0

The more load my kvm guest had the more cpu time was allocated by the kernel.
I was using 3.16.0-4-amd64.

My hostmachines were, ubuntu 14.04 and archlinux. Both same issue.

Simple solution was to install backports kernel 4.2.0-0.bpo.1-amd64 oder compile fresh vanilla kernel via make localyesconfig.

Seems to be a debian kernel bug.

Have fun!

Mikrotik SSTP 100% CPU Load

Hi

I’ve seen that due to some https requests the mikrotik SSTP server uses 100% of CPU
Here some nice script with scheduler which reenables the SSTP server. I’ve seen the bug with the latest ROS 5.20.

/system script
 add name=cpuload policy=ftp,read,write,winbox,api source=":local cpuload [ /system resource get cpu-load ]\r\
 \nif ( \$cpuload = 100 ) do {\r\
 \n/interface sstp-server server set enabled=no\r\
 \n/interface sstp-server server set enabled=yes\r\
 \n:log warning \"CPU Load \$cpuload reenabled sstp service\"\r\
 \n}"

Here the scheduler:

/system scheduler
add disabled=no interval=5m name=cpuloadsstp on-event="/system script run cpuload" policy=ftp,read,write,winbox,api start-date=\
    sep/28/2012 start-time=07:00:33

Have fun!

high cpu load due to leap second

hi

since july 1st 00:00 2012 I’ve seen high cpu load due to some java app. In my case it was the adaptec storage agent.

strace -p

showed me some problem with the realtime clock

futex(0xFUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME,ETIMEDOUT (Connection timed out)
Clock: inserting leap second 23:59:60 UTC

dmesg showed me this output

you don’t have to restart any serivce
just run the following:

/etc/init.d/ntp stop
date `date +"%m%d%H%M%C%y.%S"`
/etc/init.d/ntp start

so due to an leap second all machines running adaptec storage_agent got high cpu load 🙁

this guy reportet the bug too:
http://blog.wpkg.org … une-1-july-2012-fix/

update:
seen this bug with mysql and bind9 too